10th January 2018

Web Hosting Email Services

We are currently experiencing an unexpected issue with our email cluster causing intermittent connectivity issues to the mail servers. Our engineers are currently investigating this issue.

  • Update: @ Wed Jan 10 05:00:19 MST 2018 We are currently investigating login failure errors for users on cluster A. Mail is still being sent and received from the mail system but users are unable to login to check their email.
  • Update: @ Wed Jan 10 06:11:51 MST 2018 The operations team has resolved the webmail outage. At this time all services are back online and we do not anticipate any further issues but will continue to monitor services closely.