Thursday 2nd May 2024

Hosted Email Webmail

Title Hosted Email Webmail Login
Date Thursday 2nd May 2024
Start time 03:00 MDT

We are currently experiencing a known issue impacting Hosted Email At this time you may not be able to log in via Webmail, IMAP, or POP3. Our engineers are aware of the situation and working to resolve it. We will post updates as soon as more information is available.

We do apologize for the inconvenience.

Update @03/05/2024 03:00 AM MDT Our technical teams continue to work on implementing a fix for the IMAP/POP and Webmail issues as a priority. Once again we apologize for the inconvenience this is causing.

Update @03/05/2024 09:00 AM MDT Our team are still monitoring webmail as delays persist. Additional updates will be provided as they become available.

We understand the inconvenience this has caused and want to assure you that we are working diligently to fix it.

Update @06/05/2024 06:46 AM MDT This issue has been resolved.