Monday 22nd August 2022

Hosted Email Email - Webmail Portal

Title Hosted Email Webmail Login
Date Monday 22nd August 2022
Start time 07:00 MDT

We are currently experiencing an incident that is impacting our Hosted Email Webmail. Our Technical teams have been engaged and are investigating as a priority. We apologise for any inconvenience this may cause.

  • Update @ 08:00 MDT - Our technical teams are continuing to investigate this issue. We will provide a further update as more information becomes available.

  • Update @ 08:15 MDT - Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience.

  • Update @ 08:30 MDT - Functionality to the email service has been restored. Our engineering team is continuing to monitor the issue to ensure resolution.

  • Update @ 15:47 MDT - This issue is resolved the email service is now stable and functioning normally. We apologize for any inconvenience this may have caused.