Friday 25th February 2022

Hosted Email Hosted Email Sending/Receiving

Title Hosted Email Sending/Receiving
Date Friday 25 02 2022
Start time 10:05 MDT

Some customers may be experiencing errors when sending/receiving emails on our Hosted Email (ChiMail) platform. Technical teams are currently investigating as a priority. Further updates will be posted when available. We apologise for any inconvenience this may cause.

UPDATE - 13:30 MDT: Technical team has Identified the issue. However, there are still issues being worked on. We will provide updates as they become available.

UPDATE- 16:00 MDT: Technical team is still working to resolve this issue. We will provide further updates as they become available. UPDATE - 18:12 MDT: Normal mail service has resumed. Apologies for the inconvenience.