Wednesday 4th March 2020

Phone System Live chat and Phone support outage-Fixed

UPDATE: Our tech support has fixed the issue. We apologise for any inconvenience you might have experienced.

Issue: We are investigating and seeking to resolve an incident which is affecting our live chat and contact phone service. We recommend our customers to raise a ticket if have any concern or query. We apologise for any inconvenience this might cause.