Monday 2nd March 2020

Hosted Email Hosted email login issues

Title: Hosted email login issues Date: Monday, 2nd March 2020, 07:30 MST Event type: Minor email outage

We are currently investigating reports of not being able to access webmail, or email via mail clients, which is currently affecting a small subset of our hosted email (chimail) accounts. We apologize for any inconveniences this may cause.

  • Update @ 08:50 MST Our operations team are working on implementing a permanent fix. We will continue to provide updates as we work through this issue.

  • Update @ 10:22 MST A subset of users who try to connect to one of our IMAP nodes are not able to login to the webmail. This is due to the high load on the node. Operation team has been engaged and working on resolving the issue

If you have any questions or concerns, please contact our support team.