Saturday 6th May 2017

Shared Hosting slmp-550-42

We are aware that there are issues affecting this server. We are working to get them resolved.

Update 11:57 PM MDT: The server has been rebooted and is currently running an automatic file system check.

Update 2:10 AM MDT: The file system check is 42.4% complete.

Update 3:31 AM MDT: This server is back online.