Friday 23rd August 2019

Hosted Email Partial Email Outage

RESOLVED - 09:00 BST: Service remains stable. Please accept our apology for any inconvenience or frustration we may have caused.

UPDATE - 07:00 BST Technical teams have made some fixes and we are currently monitoring to verify these changes have corrected the intermittent email connectivity issues experienced.

UPDATE - 21.30 BST: We are continuing our investigation into an issue which some users may have trouble connecting to our Webmail, IMAP and POP service. We apologise for any inconvenience experienced during this period.

UPDATE - 17:45 BST: We are investigating an issue which some users may have trouble connecting to our Webmail, IMAP and POP service. We apologise for any inconvenience experienced during this period.

We are currently investigating an issue preventing some of our customers from accessing Hosted Email Services. We apologise for any inconvenience experienced during this period and we will keep you updated on our progress.