13th September 2018

Web Hosting Email Services

We are currently experiencing issues with our email cluster, the services may be temporarily unavailable or experience intermittent slowness. This is currently being investigated by our operations team.

Update @ Thu Sep 13 05:46:42 MDT 2018: We have identified the root cause of the outage as a DDOS and are working with our upstream network providers to resolve. This issue has the highest level of attention internally and we will provide additional updates as they become available.

Update @ Thu Sep 13 06:49:42 MDT 2018: The issue has been resolved.