25th April 2018

Web Hosting https issue on shared cPanel hosting

We are aware that there are issues affecting https ssl/tls on some of our shared cPanel servers. We are working to get them resolved.

  • update @ Wed Apr 25 11:40:31 MDT 2018 - We have identified that the cause of the issue is network related and are working to resolve the issue.

  • update @ Wed Apr 25 11:58:04 MDT 2018 - This issue has been resolved. We had an issue with one of our backbone providers blocking OSCP stapling traffic. We have routed the traffic to one of our other backbone providers.