Monday 12th February 2018

Shared Hosting Email Services

We are currently experiencing an unexpected issue with our email cluster causing intermittent connectivity issues to the mail servers. Our engineers are currently investigating this issue.

Update @ Mon Feb 12 07:47:28 MST 2018: Our operations team is continuing to work on the issues impacting the email cluster performance.

Update @ Mon Feb 12 09:59:21 MST 2018: The issues we were experiencing are now resolved. Thank you for your patience in this matter.