Back to overview

Webmail URL Connectivity Issues

Feb 24 at 01:13pm GMT
Affected services
Stack Webmail

Resolved
Feb 24 at 01:13pm GMT

We’re currently investigating an issue affecting access to the webmail login page. At the moment, some users may be unable to sign in via the usual webmail portal.

Important: Mail sending and receiving are not affected and continue to work as expected.

As a temporary workaround, you can access your mailbox using the alternative webmail URL: https://stackmail.com

We’ll provide further updates as soon as we have more information. Thank you for your patience.

UPDATE: We are seeing access to Webmail at https://us.stackmail.com return, we are monitoring this further.