Back to overview
Resolved

StackCP Interface performance issue

Aug 20, 2026 at 1:34pm UTC
Affected services
Stack CP (Hosting Control Panel)

Resolved
Aug 20, 2026 at 4:00pm UTC

The issues affecting the StackCP interface have now been resolved, and the service is back operating normally.

Our team has investigated the issues and we are satisfied that performance has returned to normal. We will continue to monitor the service closely to ensure stability.

We apologise for any inconvenience caused and thank you for your patience while we investigated the issue.

Created
Aug 20, 2026 at 1:34pm UTC

We are currently experiencing load time issues with the StackCP interface. Some users may also experience a "429 Too Many Requests" error.

Our system administrators are actively working to resolve the issue and restore normal performance and uptime. We will provide an update here as soon as we have more information.

Thank you for your patience and understanding.