Wednesday 7th September 2022

Live Chat Live chat and phone system unavailable

Title Live Chat + Phone system unavailable Date Wednesday 7th September 2022
Start time 01:15 MDT

Our phone and live chat system is currently unavailable. Technical teams have been engaged and are investigating to get the system back up as soon as possible. Should you require any assistance, please create a ticket at https://midphase.com/support

  • Update @ 01:53 MDT - Our technical teams have applied a fix and we are seeing improvements to the affected services. We will continue to monitor services and will update you once the incident has been confirmed as resolved.
  • Update @ 02:14 MDT - Technical teams are continuing to investigate the issue. Further updates will be provided as they become available.
  • Update @ 02:45 MDT - Our technical teams have applied a fix and services have been restored. We will continue to monitor services, thank you for your patience.
  • Update @ 03:20 MDT - This issue has now been resolved.