26th July 2017

Web Hosting email

Investigating - We have identified an issue on Cluster A that is resulting in delays with email forwarding. Our operations team is aware of the problem and they are working towards a resolution. We apologise for the inconvenience. Jul 26, 17:02 UTC

  • Update @ Wed Jul 26 11:54:22 MDT 2017- All Systems Operational