Tuesday 19th October 2021

Hosted Email Webmail Login issue - IMAP, POP, and Webmail

Title Hosted Email Login - IMAP, POP, and Webmail

Date 19/10/2021

Start time 21:48 MDT

We are currently experiencing an incident that is impacting our Hosted Email Web Login. Our Technical teams have been engaged and are investigating as a priority.

UPDATE - 22:13 MDT ** Our technical teams have completed the investigation and all mail services are resumed to fully operational with no further login issues. we are monitoring the state. We apologize for any inconvenience this may have caused.

UPDATE - 23:07 MDT ** Email services (IMAP/POP/Webmail/Inbound emails) are offline again. Technical teams are continuing to investigate the issue. Further updates will be provided as they become available.

Resolved A fix has been implemented and the hosted email web login, is now accessible. We apologize for any inconvenience this may have caused.