Friday 4th June 2021

Hosted Email Hosted Email Delays (receiving)

Title Hosted Email Delays (receiving)

Date 04/06/2021

Start time 17:34 UTC

We are experiencing email delays. We will provide an update shortly with additional information.

UPDATE - 19:27 UTC: The deployed team has identified the issues causing delays and are taking measures to resolve the said delays and deferrals. Deferrals and delays are still expected.

UPDATE - 21:15 UTC: The mail admin team continues working to resolve the problems in our hosted email service.

UPDATE - Jun 05, 2021 - 09:29 UTC This issue has been resolved as we are no longer seeing issues with new inbound emails.