Thursday 28th January 2021

Hosted Email Mailbox Notification- hosted email

Title: False alert on hosted email

We are currently investigating emails being sent in error to users by our mail service

There is no percentage specified in these notifications, and they have no impact on the use of the mailboxes, sending, and receiving. You can disregard the emails and continue to use your account as normal.

UPDATE @ 11:15 GMT We are continuing to investigate this issue but can confirm this isn't impacting mail service. We will post updates as they are available.

UPDATE @ 14:20 GMT We are continuing to investigate the issue and will post updates as they become available.

UPDATE @ 17:50 GMT We are continuing to investigate this issue but can confirm this isn't impacting mail service. We will post updates as they are available.

UPDATE @ 20:05 GMT Our engineers have implemented a fix to resolve the issue with the email notifications, users should no longer expect to receive quota notification.

We apologise for the inconvenience this has caused.