15th May 2020

Hosted Email Connectivity issue with webmail

We are currently investigating reports of a functionality issue with our mail system. A small set of users may experience the inability to access mailboxes. Our senior engineers are investigating the problem and will look to resolve this as a matter of urgency.

UPDATE Mail system issues are still being investigated. Your patience is greatly appreciated regarding this issue.

UPDATE: We have had notification from mail engineers that this incident is now resolved. Again we appreciate your patience through this isssue.