Wednesday 25th March 2020

Hosted Email Hosted Email Update
  • UPDATE @ 26th March 2020, 17:13 UTC - Our operations team continues to restore service on the affected mailstores. The service has been restored for some customers but a small portion of our customers continue to experience issues with their mailboxes.

  • UPDATE @ 26th March 2020, 12:05 UTC - Most of the affected mailstores have been re-enabled. While the operations team continues to investigate another to identify and rectify the issue on it. Updates will be provided as soon as possible. Please ensure that, before you contact support regarding this query, you attempt to log into your webmail account to verify that your account is now active, by going to https://chimail.midphase.com

  • UPDATE @ 26th March 2020, 11:10 UTC - After re-enabling our mailstores to resolve this ongoing incident we have encountered a different issue and needed to bring the mailstores offline again in order to resolve this problem. We will likely be bringing them back up shortly once we have completed testing. These affected users will be unable to login to the Webmail/IMAP or POP until the mailstores have been re-established.

  • UPDATE @ 26th March 2020, 10:00 UTC - The mailstores have been re-enabled. At this time service is fully online and we will be monitoring for any impact which is currently expected to be better than previous days.

  • UPDATE @ 26th March 2020, 07:56 UTC - The emergency maintenance will be targeted for specific users. Those targeted users will be unable to login to their account via POP/IMAP/Webmail or an email client during the maintenance window. This would affect approx. 6.6% of users

We will be performing emergency maintenance this evening to resolve outstanding issues on this platform.

A small number of users may encounter issues logging in to their account via POP/IMAP/Webmail during the maintenance window.

We thank you once again for your continued patience and understanding whilst we work to resolve this issue.

Start time: Mar 25, 2020 at 10:00 PM UTC End time: Mar 26, 2020, at 10:00 AM UTC