Wednesday 11th March 2020

Live Chat Live Chat and Phone Outage

Title: Live chat and phone degraded performance Date: Wednesday, 11th March 2020 Start time: 03:07am MDT/09:07am UTC Event type: Outage

We are investigating and seeking to resolve an incident is affecting our live chat and phone service. Customers may be experiencing delays in allocating requests to available agents. Our Operations team are currently investigating this issue as a priority.

We apologize for the potential impact of this incident on you.

  • Update @ 04:35am MDT/10:35am UTC - Our engineers have applied a fix and identified that normal service is currently being resumed. We will continue to monitor services and will update the incident once it has been confirmed as resolved.

  • Update @ 05:01am MDT/11:01am UTC - Following a period of monitoring, our engineers have confirmed that the incident is now resolved and normal service has resumed. Please accept our apologies for the potential impact this incident may have caused.