Thursday 6th February 2020

CHI Control Panel Issues with domain registration, domain transfer, domain pushes and contact information change

FIXED:

The issue has been fixed and all services are now fully operational. We apologise for any incovenience experienced during this incident.

Identified:

We have identified the issue and have applied a fix but are still seeing intermittent failures on some accounts. Thank you for your continued patience with this case as we investigate further.

We are currently investigating issues affecting the following services: Domain Registrations, Domain Transfers, Domain Pushes and Contact Information changes.

Our support team is looking into the issue. We will keep you posted as new information is made available.