Saturday 29th June 2019

Shared Hosting slmp-550-101.slc.westdc.net

We are aware that there are issues affecting this server. We are working to get them resolved.

Update @ Sat Jun 29 10:33:40 MDT 2019: The server unexpectedly crashed and is being rebooted to restore service.

Update @ Sat Jun 29 10:39:04 MDT 2019: The server is online and available for use.